Basic Router on a Stick

Router on a Stick

Router on a stick : 

The term router on a stick is used  widely, meaning one link that provides access to multiple networks ( vlans ). With this we configure a trunk from router to switch over ethernet. Above vlan 19, 20, 21 is what I'm using and we have no layer 3 switching or extra equipment to divide up the networks with multiple areas so we use what we have to make it work.

DHCP:

Each of the vlans will be giving off DHCP for the following subnets

VLAN 19:      19.5.5.0   255.255.255.0

VLAN 20:      20.5.5.0   255.255.255.0

VLAN 21:      21.5.5.0    255.255.255.0



R1:


!

hostname R1

!


ip dhcp excluded-address 20.5.5.1

ip dhcp excluded-address 19.5.5.1
ip dhcp excluded-address 21.5.5.1
!
ip dhcp pool vlan19
   network 19.5.5.0 255.255.255.0
   default-router 19.5.5.1 
!
ip dhcp pool vlan20
   network 20.5.5.0 255.255.255.0
   default-router 20.5.5.1 
!
ip dhcp pool vlan21
   network 21.5.5.0 255.255.255.0
   default-router 21.5.5.1 

!

no ip domain lookup
ip domain name lab.local
!

interface FastEthernet0/0

 no ip address
 speed auto
 full-duplex
!
interface FastEthernet0/0.19
 description VLAN19_Servers
 encapsulation dot1Q 19
 ip address 19.5.5.1 255.255.255.0
 no snmp trap link-status
!
interface FastEthernet0/0.20
 description VLAN20_Servers
 encapsulation dot1Q 20
 ip address 20.5.5.1 255.255.255.0
 no snmp trap link-status
!
interface FastEthernet0/0.21
 description VLAN21_Servers
 encapsulation dot1Q 21
 ip address 21.5.5.1 255.255.255.0
 no snmp trap link-status
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous



SW1:


hostname Switch
!

interface FastEthernet0/1

 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 19
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 21
 switchport mode access



Comments

Popular posts from this blog

HULC LED PROCESS - 3750 High CPU

%PLATFORM_UCAST-4-PREFIX: --------- TCAM 3750 Switch