Basic Ripv2

This is a basic RIPv2 topology using GNS3. GNS3 is a great program if you get a chance to use it, I like all the functionality it has to it.

So some facts/updates about RIPv2

  •     Distance Vector Protocol 
  •     Routing updates sent via multicast at 224.0.0.9  as opposed to RIPv1 which uses broadcast
  •     You must enable version 2 when configuring !  " version 2" ( You will see the configuration down the page)
  • Administrative Distance of 120

So now that we have a couple updates on RIPv2 we are going to configure a basic RIP topology and when you're done you should be able to go to R1 and see the following "show ip route":

   1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/2] via 172.19.33.2, 00:00:20, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
R       3.3.3.3 [120/1] via 172.19.33.2, 00:00:20, FastEthernet0/0
     172.19.0.0/30 is subnetted, 2 subnets
R       172.19.38.0 [120/1] via 172.19.33.2, 00:00:20, FastEthernet0/0
C       172.19.33.0 is directly connected, FastEthernet0/0


As you can see above we see all of the routes for the loopback interfaces that we made as the potential networks behind the router.

Network Configuration:

R1

interface loopback 0 
ip add 1.1.1.1 255.255.255.255 ( All 255's is the same as a /32 )
no shut
description R1 Fake Network


interface fa0/0
ip add 172.19.33.1 255.255.255.252 ( We make it a /30 for the two IP's needed on both ends of the connection)
no shut
description Link to R3 ( Whenever you can always use descriptions ! )

router rip  ( Enable RIP Routing Protocol)
version 2  ( This enables RIPv2 otherwise we would have version 1)
network 1.1.1.1 
network 172.19.33.0
no auto-summary ( This configuration allows you to have classless networks being advertised instead of classful so if we only want to advertise 1.1.1.1/32 we use "no auto summary" but naturally 1.1.1.1 is a class A so we would see if advertised as 1.0.0.0)


R3

interface loopback 0
ip add 3.3.3.3 255.255.255.255
no shut
description R3 Fake Network


interface fa0/0
ip add 172.19.33.2 255.255.255.252
no shut 
description Link to R1

interface fa0/1
ip add 172.19.38.2 255.255.255.252
no shut
description Link to R2


router rip 
version 2
network 3.3.3.3
network 172.19.33.0
network 172.19.38.0
 (  RIP Routing Table will automatically make the 172.19.X.X addresses into 172.19.0.0 which we could configure as well but for an example to see both network configurations we will configure both) 
network 172.19.38.0 and 172.19.33.0)
no auto-summary



R2


interface loopback 0
ip add 2.2.2.2 255.255.255.255
no shut
description R2 Fake Network


interface fa0/1
 description Link to R3
 ip address 172.19.38.1 255.255.255.252
no shut

router rip 
version 2
network 2.2.2.2
network 172.19.38.0
no auto-summary 






















Comments

Popular posts from this blog

HULC LED PROCESS - 3750 High CPU

%PLATFORM_UCAST-4-PREFIX: --------- TCAM 3750 Switch