Basic Step of SIP Trunk / H323 Gateway
Below is the IOS configuration from my lab for a SIP trunk to the sip provider and h323 gateway configured in Call Manager:
**** This is only for incoming calls. Outbound call isn't fully configured.
Voicegateway Configuration:
!
!
!
ip domain name lab.local
ip name-server 8.8.8.8
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
h323
sip
bind control source-interface FastEthernet0/0
bind media source-interface FastEthernet0/0
!
!
!
!
voice class h323 1
!
!
!
!
!
voice translation-rule 1
rule 1 /Inbound PSTN Number/ /4200/
!
!
voice translation-profile CALLED
translate called 1
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
description Main Link to Switch
ip address 192.168.255.33 255.255.255.0
ip helper-address 192.168.2.1
ip helper-address 192.168.3.1
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip h323-id 192.168.255.33
h323-gateway voip bind srcaddr 192.168.255.33
!
ip route 0.0.0.0 0.0.0.0 192.168.255.34
!
ip http server
ip http secure-server
!
!
!
control-plane
!
!
!
voice-port 1/0/0
signal groundStart
!
voice-port 1/0/1
signal groundStart
!
voice-port 1/1/0
!
voice-port 1/1/1
!
!
!
!
dial-peer voice 1 voip
description 10 Digit
destination-pattern [2-9]..[2-9]......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 2 voip
description 11 Digit
destination-pattern 1[2-9]..[2-9]......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 3 voip
description VoiceLab
destination-pattern ....
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 4 voip
description Incoming from SIP Trunk
translation-profile incoming CALLED
preference 1
session protocol sipv2
session target sip-server
incoming called-number .
dtmf-relay h245-alphanumeric h245-signal
codec g711ulaw
no vad
!
dial-peer voice 5 voip
description Going to CUCM 4digit Extensions
destination-pattern ....
session target ipv4:<CUCM IP>
!
!
sip-ua
credentials username <PutUSER> password <PutPassword> realm sipprovider.com
authentication username <PutUSER> password 7 <PutPassword>
registrar dns:proxy.sipprovider.com expires 60
sip-server dns:proxy.sipprovider.com
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
**** This is only for incoming calls. Outbound call isn't fully configured.
Voicegateway Configuration:
!
!
!
ip domain name lab.local
ip name-server 8.8.8.8
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
h323
sip
bind control source-interface FastEthernet0/0
bind media source-interface FastEthernet0/0
!
!
!
!
voice class h323 1
!
!
!
!
!
voice translation-rule 1
rule 1 /Inbound PSTN Number/ /4200/
!
!
voice translation-profile CALLED
translate called 1
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
description Main Link to Switch
ip address 192.168.255.33 255.255.255.0
ip helper-address 192.168.2.1
ip helper-address 192.168.3.1
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip h323-id 192.168.255.33
h323-gateway voip bind srcaddr 192.168.255.33
!
ip route 0.0.0.0 0.0.0.0 192.168.255.34
!
ip http server
ip http secure-server
!
!
!
control-plane
!
!
!
voice-port 1/0/0
signal groundStart
!
voice-port 1/0/1
signal groundStart
!
voice-port 1/1/0
!
voice-port 1/1/1
!
!
!
!
dial-peer voice 1 voip
description 10 Digit
destination-pattern [2-9]..[2-9]......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 2 voip
description 11 Digit
destination-pattern 1[2-9]..[2-9]......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 3 voip
description VoiceLab
destination-pattern ....
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 4 voip
description Incoming from SIP Trunk
translation-profile incoming CALLED
preference 1
session protocol sipv2
session target sip-server
incoming called-number .
dtmf-relay h245-alphanumeric h245-signal
codec g711ulaw
no vad
!
dial-peer voice 5 voip
description Going to CUCM 4digit Extensions
destination-pattern ....
session target ipv4:<CUCM IP>
!
!
sip-ua
credentials username <PutUSER> password <PutPassword> realm sipprovider.com
authentication username <PutUSER> password 7 <PutPassword>
registrar dns:proxy.sipprovider.com expires 60
sip-server dns:proxy.sipprovider.com
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
Comments
Post a Comment