Routing Jungle Basic Redistribution - RIP , OSPF ( Backbone Only), EIGRP, STATICs
While just messing around. I decided to do a quick little routing lab on GNS3 for fun. The table includes rip, eigrp, ospf, and static routing. Each of the 4 networks connects to a central hub that is pretty much the redistribution hub.
The purpose of this was just to have 4 completely separate network zones with over 20+ network subnets pinging each other fully.
After all said and done the routing table should like the following on the "HUB" or middle router:
CONFIGURATION:
Nick Router:
Middle / HUB Router :
hostname R2
!
ip domain name lab.local
!
ip address 10.1.1.9 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
ip address 10.1.1.13 255.255.255.252
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.1.5 255.255.255.252
clock rate 8000000
!
router eigrp 24
redistribute static metric 1544 20000 255 1 1500
redistribute ospf 69 metric 1544 20000 255 1 1500
redistribute rip metric 1544 20000 255 1 1500
network 10.1.1.0 0.0.0.3
no auto-summary
!
router ospf 69
log-adjacency-changes
redistribute static metric 50 subnets
redistribute eigrp 24 subnets
redistribute rip metric 50 subnets
network 10.1.1.4 0.0.0.3 area 0
!
router rip
version 2
redistribute static metric 4
redistribute eigrp 24 metric 3
redistribute ospf 69 metric 3
network 1.0.0.0
network 10.0.0.0
no auto-summary
!
ip route 1.1.30.0 255.255.255.0 10.1.1.14
ip route 1.1.31.0 255.255.255.0 10.1.1.14
ip route 1.1.32.0 255.255.255.0 10.1.1.14
ip route 1.1.33.0 255.255.255.0 10.1.1.14
ip route 1.1.34.0 255.255.255.0 10.1.1.14
!
no ip http secure-server
!
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
logging synchronous
!
The purpose of this was just to have 4 completely separate network zones with over 20+ network subnets pinging each other fully.
After all said and done the routing table should like the following on the "HUB" or middle router:
Nick Router:
hostname NickRouter
!
no ip domain lookup
ip domain name lab.local
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
ip address 1.1.2.1 255.255.255.0
!
interface Loopback2
ip address 1.1.3.1 255.255.255.0
!
interface Loopback3
ip address 1.1.4.1 255.255.255.0
!
interface Loopback4
ip address 1.1.5.1 255.255.255.0
!
interface Serial0/0
ip address 10.1.1.2 255.255.255.252
clock rate 8000000
!
router eigrp 24
network 1.0.0.0
network 10.1.1.0 0.0.0.3
no auto-summary
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
logging synchronous
!
Mike Router:
!
hostname MikeRouter
!
no ip domain lookup
ip domain name lab.local
!
username nick privilege 15 nopassword - was using this to remote in from local PC
!
interface Loopback0
ip address 1.1.20.1 255.255.255.0
!
interface Loopback1
ip address 1.1.21.1 255.255.255.0
!
interface Loopback2
ip address 1.1.22.1 255.255.255.0
!
interface Loopback3
ip address 1.1.23.1 255.255.255.0
!
interface Loopback4
ip address 1.1.24.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.1.10 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 1.0.0.0
network 10.0.0.0
no auto-summary
!
no ip http server
no ip http secure-server
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
privilege level 15
logging synchronous
login local
!
Chris Router:
hostname ChrisRouter
!
no ip domain lookup
ip domain name lab.local
!
interface Loopback0
ip address 1.1.10.1 255.255.255.0
ip ospf network point-to-point --- By default when you do a "sh ip route" in the "hub" router ( middle router) the networks will come up as a /32 or 255.255.255.255. So by labeling the networks as point to point we can make sure the network comes up properly as a /24 subnet listed.
!
interface Loopback1
ip address 1.1.11.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback2
ip address 1.1.12.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback3
ip address 1.1.13.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback4
ip address 1.1.14.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
ip address 10.1.1.6 255.255.255.252
clock rate 2000000
!
router ospf 69
log-adjacency-changes
network 1.1.10.0 0.0.0.255 area 0
network 1.1.11.0 0.0.0.255 area 0
network 1.1.12.0 0.0.0.255 area 0
network 1.1.13.0 0.0.0.255 area 0
network 1.1.14.0 0.0.0.255 area 0
network 10.1.1.4 0.0.0.3 area 0
!
!
no ip http server
no ip http secure-server
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
logging synchronous
!
Static Router:
hostname StaticRouter
!
no ip domain lookup
ip domain name lab.local
!
interface Loopback0
ip address 1.1.30.1 255.255.255.0
!
interface Loopback1
ip address 1.1.31.1 255.255.255.0
!
interface Loopback2
ip address 1.1.32.1 255.255.255.0
!
interface Loopback3
ip address 1.1.33.1 255.255.255.0
!
interface Loopback4
ip address 1.1.34.1 255.255.255.0
!
interface FastEthernet0/1
ip address 10.1.1.14 255.255.255.252
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 10.1.1.13 name HopToDistributionRouter - You can name routes if you have many to understand the functions. I like to use this function for an easy way to remember why I may have put the route there in the first place.
!
no ip http server
no ip http secure-server
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
logging synchronous
!
Middle / HUB Router :
hostname R2
!
no ip domain lookup
ip domain name lab.local
!
interface FastEthernet0/0
ip address 10.1.1.9 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
ip address 10.1.1.13 255.255.255.252
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.1.5 255.255.255.252
clock rate 8000000
!
router eigrp 24
redistribute static metric 1544 20000 255 1 1500
redistribute ospf 69 metric 1544 20000 255 1 1500
redistribute rip metric 1544 20000 255 1 1500
network 10.1.1.0 0.0.0.3
no auto-summary
!
router ospf 69
log-adjacency-changes
redistribute static metric 50 subnets
redistribute eigrp 24 subnets
redistribute rip metric 50 subnets
network 10.1.1.4 0.0.0.3 area 0
!
router rip
version 2
redistribute static metric 4
redistribute eigrp 24 metric 3
redistribute ospf 69 metric 3
network 1.0.0.0
network 10.0.0.0
no auto-summary
!
ip route 1.1.30.0 255.255.255.0 10.1.1.14
ip route 1.1.31.0 255.255.255.0 10.1.1.14
ip route 1.1.32.0 255.255.255.0 10.1.1.14
ip route 1.1.33.0 255.255.255.0 10.1.1.14
ip route 1.1.34.0 255.255.255.0 10.1.1.14
!
no ip http server
no ip http secure-server
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
logging synchronous
!
Comments
Post a Comment