DHCP with Basic EIGRP

Throughout this lab are DHCP scopes defined on each network router. All scopes are a /24 subnet.  We separate the subnets with VLAN's. Each network is running the following vlan configuration:


Configured on all switches: 

vlan 10
name SERVERS
vlan 20
name DATA
vlan 30
name GAMING
vlan 40
name GUEST



interface FastEthernet0/1 (create a trunk from switch to router that carries over all vlan traffic)
 switchport mode trunk

interface fa0/X ( "X" represents the interface number that you will configure)


switchport mode access ( make it an access port for the PC, laptop, server, etc)
switchport access vlan X ( "X" represents the VLAN access you will give the device plugged into this port to allow it to request DHCP from the appropriate scope)

The following is the EIGRP configuration for each network to talk back to the other networks:

Nick Network
router eigrp 24
network 1.1.1.0 0.0.0.15
network 192.168.1.0 0.0.7.255
no auto-summary
Mike Network
router eigrp 24
network 1.1.1.0 0.0.0.15
network 192.169.1.0 0.0.7.255
no auto-summary
Chris Network
router eigrp 24
network 1.1.1.0 0.0.0.15
network 192.170.1.0 0.0.7.255
no auto-summary


I will post the configuration for one network because this is pretty straight forward for the change with each subnet. All networks are very similar the only difference is the second octect!! So for example we will replace " 192.X.1.0 "  the X with the location of the network whether it is Nick, Mike or Chris.

Nick Network:
192.168.1.0  - VLAN 10
192.168.2.0 - VLAN 20
192.168.3.0 - VLAN 30
192.168.4.0 - VLAN 40

Mike Network
192.169.1.0 - VLAN 10
192.169.2.0 - VLAN 20
192.169.3.0 - VLAN 30
192.169.4.0 - VLAN 40

Chris Network
192.170.1.0 - VLAN 10
192.170.2.0 - VLAN 20
192.170.3.0 - VLAN 30
192.170.4.0 - VLAN 40

***Remember the biggest difference with all the configuration are the numbers in red listed above in the second octect. Everything else is pretty much the same so I will post one configuration****


Create DHCP Excluded Addresses on Router:

ip dhcp excluded-address 192.170.1.1   ( We want to exclude the router address from being handed out. We can add a range of addresses but for simplicity we will just do the router for now)
ip dhcp excluded-address 192.170.2.1
ip dhcp excluded-address 192.170.3.1
ip dhcp excluded-address 192.170.4.1

Create DHCP Pools for each subnet:

ip dhcp pool SERVERS  (create the pool and name it !)
network 192.170.1.0 255.255.255.0  ( define the network you will create a pool for)
default-router 192.170.1.1     ( default router is the default gateway you will put on your PC)


ip dhcp pool DATA
network 192.170.2.0 255.255.255.0
default-router 192.170.2.1


ip dhcp pool GAMING
network 192.170.3.0 255.255.255.0
default-router 192.170.3.1 

ip dhcp pool GUEST
network 192.170.4.0 255.255.255.0
default-router 192.170.4.1

Create Router with Sub Interfaces for all the Vlans!
interface fa0/0    ( fa0/0 will be the main interface that we create sub interfaces from based on the VLAN)
no shut ( make sure you turn on fa0/0 so all sub interfaces work !)
description Link to Local LAN


interface fa0/0.10  ( creates a sub interface of fa0/0 using vlan 10)
no shut
encapsulation dot1q 10 ( define vlan 10 as the advertised vlan for trunking from router to switch)
ip add 192.170.1.1 255.255.255.0 ( This is our IP address we excluded to use for the router aka default gateway for the network !)
description SERVERS NETWORK 

interface fa0/0.20
no shut
encapsulation dot1q 20
ip add 192.170.2.1 255.255.255.0
description DATA NETWORK

interface fa0/0.30
no shut
encapsulation dot1q 30
ip add 192.170.3.1 255.255.255.0
description GAMING NETWORK

interface fa0/0.40
no shut
encapsulation dot1q 40
ip add 192.170.4.1 255.255.255.0
description GUEST NETWORK


Outside Facing Interfaces:

This configuration is for the interfaces that are connecting to the other networks outside the one you may be working on or in.


Nick Network:
!

interface FastEthernet0/1
 description Link to Chris Network
 ip address 1.1.1.5 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 description Link to Mike Network
 ip address 1.1.1.1 255.255.255.252
 duplex auto
 speed auto

Mike Network:

!
interface FastEthernet0/1
 description Link to Chris Network
 ip address 1.1.1.9 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 description Link to Nick Network
 ip address 1.1.1.2 255.255.255.252
 duplex auto
 speed auto


Chris Network:

interface FastEthernet0/1
 description Link to Nick Network
 ip address 1.1.1.6 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 description Link to Mike Network
 ip address 1.1.1.10 255.255.255.252
 duplex auto
 speed auto
!






AFTER THE CONFIGURATION IS ALL DONE YOU SHOULD HAVE FULL CONNECTIVITY !!!!!! 

Comments

  1. Great info! I recently came across your blog and have been reading along. I thought I would leave my first comment. I don’t know what to say except that I have.
    Minecraft Server

    ReplyDelete

Post a Comment

Popular posts from this blog

HULC LED PROCESS - 3750 High CPU

%PLATFORM_UCAST-4-PREFIX: --------- TCAM 3750 Switch