Basic Static Routes
In this LAB it is basic static routing that allows us have communication between all networks. This topology was built using packet tracer. What was put in was several different ways to do basic static routing either with one or two static routes.
Also for ease of use all devices have the same following information:
enable secret cisco
line con 0
logging sync
password cisco
login
line vty 0 4
logging sync
password cisco
login
Nick Router:
Networks :
192.168.20.0/26
192.168.20.64/26
172.16.20.0/24 ( We could really just make this a /30 but for simplicity it was a /24)
Nick Router Configuration:
interface fa0/0
ip add 192.168.20.1 255.255.255.192
no shut
description Link to Switch
interface fa0/1
ip add 192.168.20.65 255.255.255.192
no shut
description Link to Nick Laptop
interface ser0/0/0
ip add 172.16.20.2 255.255.255.0 ( Remember we can make this a /30 ... aka ending octet .252)
no shut
description Link to MainRouter
ip route 192.168.20.128 255.255.255.128 Ser0/0/0 (The /25 will cover the two /26 Networks in the Hayat Network)
ip route 172.31.20.0 255.255.255.0 Ser0/0/0
Hayat Router:
Networks :
192.168.20.192/26
192.168.20.128/26
172.31.20.0/24 ( We could really just make this a /30 but for simplicity it was a /24)
Hayat Network Configuration:
interface fa0/0
ip add 192.168.20.129 255.255.255.192
no shut
description Link to Hayat Switch
interface fa0/1
ip add 192.168.20.193 255.255.255.192
no shut
description Link to Hayat Laptop
interface ser0/0/0
ip add 172.31.20.2 255.255.255.0 ( Remember we can make this a /30 ... aka ending octet .252)
no shut
description Link to MainRouter
ip route 0.0.0.0 0.0.0.0 ser0/0/0 ( Default Static Route Instead of Two Routes)
Main Router:
Networks :
172.16.20.0 /24
172.31.20.0/24
Main Router Network Configuration:
interface ser0/3/0
ip add 172.16.20.1 255.255.255.0
no shut
description Link to Nick Network
clock rate 250000 ( We set the clock rate and bandwidth because this is the DCE end )
bandwidth 250
interface ser0/3/1
ip add 172.31.20.1 255.255.255.0
no shut
description Link to Hayat Network
clock rate 4000000 (Set that clock rate like your the Internet Service Provider!)
bandwidth 4000
Two Static Routes that Cover Hayats Network
ip route 192.168.20.192 255.255.255.192 Ser0/3/1
ip route 192.168.20.128 255.255.255.192 Ser0/3/1
OR
One Static Route that Covers Nicks Network
ip route 192.168.20.0 255.255.255.128 Ser0/3/0
Also for ease of use all devices have the same following information:
enable secret cisco
line con 0
logging sync
password cisco
login
line vty 0 4
logging sync
password cisco
login
Nick Router:
Networks :
192.168.20.0/26
192.168.20.64/26
172.16.20.0/24 ( We could really just make this a /30 but for simplicity it was a /24)
Nick Router Configuration:
interface fa0/0
ip add 192.168.20.1 255.255.255.192
no shut
description Link to Switch
interface fa0/1
ip add 192.168.20.65 255.255.255.192
no shut
description Link to Nick Laptop
interface ser0/0/0
ip add 172.16.20.2 255.255.255.0 ( Remember we can make this a /30 ... aka ending octet .252)
no shut
description Link to MainRouter
ip route 192.168.20.128 255.255.255.128 Ser0/0/0 (The /25 will cover the two /26 Networks in the Hayat Network)
ip route 172.31.20.0 255.255.255.0 Ser0/0/0
Hayat Router:
Networks :
192.168.20.192/26
192.168.20.128/26
172.31.20.0/24 ( We could really just make this a /30 but for simplicity it was a /24)
Hayat Network Configuration:
interface fa0/0
ip add 192.168.20.129 255.255.255.192
no shut
description Link to Hayat Switch
interface fa0/1
ip add 192.168.20.193 255.255.255.192
no shut
description Link to Hayat Laptop
interface ser0/0/0
ip add 172.31.20.2 255.255.255.0 ( Remember we can make this a /30 ... aka ending octet .252)
no shut
description Link to MainRouter
ip route 0.0.0.0 0.0.0.0 ser0/0/0 ( Default Static Route Instead of Two Routes)
Main Router:
Networks :
172.16.20.0 /24
172.31.20.0/24
Main Router Network Configuration:
interface ser0/3/0
ip add 172.16.20.1 255.255.255.0
no shut
description Link to Nick Network
clock rate 250000 ( We set the clock rate and bandwidth because this is the DCE end )
bandwidth 250
interface ser0/3/1
ip add 172.31.20.1 255.255.255.0
no shut
description Link to Hayat Network
clock rate 4000000 (Set that clock rate like your the Internet Service Provider!)
bandwidth 4000
Two Static Routes that Cover Hayats Network
ip route 192.168.20.192 255.255.255.192 Ser0/3/1
ip route 192.168.20.128 255.255.255.192 Ser0/3/1
OR
One Static Route that Covers Nicks Network
ip route 192.168.20.0 255.255.255.128 Ser0/3/0
Comments
Post a Comment